Java がクラッシュした後、デスクトップに hs_log_pid のログファイルが置かれるのはなぜですか。
このトピックは、次に当てはまります。:
- プラットフォーム: Windows 7, Windows XP, Windows Vista
- Javaバージョン: 7.0, 8.0
症状
ブラウザ内でのアプレットまたはアプリケーションの実行中に Java のクラッシュが発生すると、デスクトップにテキスト (.log) ファイルが表示される。テキストファイルの名前は hs_err_pid で始まります。ファイルには、次のエラーメッセージが記録されています。
エラーメッセージ: 「HotSpot 仮想マシンにより予期しないエラーが検出されました。」

原因
アプレットがクラッシュする原因は多数あります。以下に、考えられる原因を示します。
- 実行したアプリケーションやアプレットに Java をクラッシュさせるプログラミングエラーまたはバグが含まれていた。
- Java をクラッシュさせるバグが残っている可能性がある旧バージョンの Java を実行した可能性がある。
回避策
注: デスクトップ上のログファイルは削除しても安全です。
- Javaのバージョンの確認 アプレットを実行して、システム上に Java が正しくインストールされているかどうかを確認します。このアプレットを実行できる場合は、システム上に Java が正しくインストールされ、構成されています。特定のアプレットでのみ問題が発生する場合があります。その場合は、その Web サイトの管理者またはソフトウェアの製造元に問題を報告してください。
- 最新の Java をダウンロードし、インストールします。最新バージョンには、この問題が発生しないアップデート版やバグフィックスが含まれていることがあります。