Java.com

Download Guida in linea

Perché è necessario disinstallare le versioni precedenti di Java dal sistema?


Questo articolo è relativo a:
  • Piattaforme: Windows 2000, Windows 7, Windows 8, Windows XP

Si consiglia sempre la versione più recente di Java, poiché contiene aggiornamenti delle funzionalità, correzioni delle vulnerabilità e miglioramenti delle prestazioni rispetto alle versioni precedenti. Per confermare di disporre della versione più aggiornata, visitate la pagina di verifica di Java.

Perché è necessario disinstallare le versioni precedenti di Java?

Consigliamo di disinstallare tutte le versioni precedenti di Java dal proprio sistema.
Conservare nel sistema versioni obsolete di Java rappresenta un grave rischio per la sicurezza.
Con la disinstallazione delle versioni precedenti di Java dal sistema, si garantisce che le applicazioni Java verranno eseguite utilizzando i miglioramenti più recenti in termini di prestazioni e sicurezza nel sistema.

Come si rimuovono le versioni precedenti di Java?

È possibile disinstallare in sicurezza le versioni precedenti di Java dal sistema mediante lo strumento di disinstallazione di Java o seguendo le istruzioni contenute nella pagina relativa alla disinstallazione manuale di Java per Windows.

Utenti Windows: migliorate la sicurezza del vostro computer controllando la presenza di versioni precedenti di Java e rimuovendole con lo strumento di disinstallazione di Java.

» Ulteriori informazioni sullo strumento di disinstallazione di Java

Come si rimuove Java dal computer?

Windows: è possibile disinstallare le versioni di Java manualmente nello stesso modo in cui si disinstalla qualsiasi altro software dal computer Windows. Seguite le istruzioni per la disinstallazione manuale di Java per Windows.
» Istruzioni per la disinstallazione di Java su Mac
» istruzioni per la disinstallazione di Java su Linux.

È necessario disporre di versioni meno recenti di Java?

La versione più aggiornata disponibile è compatibile con le versioni precedenti. Tuttavia, alcune applicazioni (o applet) di Java possono indicare di dipendere da una versione specifica e potrebbero non essere eseguite se non si dispone di quella versione. Se un'applicazione o una pagina Web alla quale effettuate l'accesso vi richiede una versione precedente di Java, indicatelo al fornitore o allo sviluppatore, richiedendo l'aggiornamento dell'applicazione affinché sia compatibile con tutte le versioni di Java.


Si potrebbe essere interessati anche a:



Scegli una lingua | Informazioni su Java | Supporto | Sviluppatori
Privacy | Termini e condizioni per l'utilizzo | Marchi | Dichiarazione di non responsabilità

Oracle