Java.com

Download Guida in linea

Risorse di assistenza

Perché è necessario Java 6 Aggiornamento 10 o versioni successive per Firefox 3.6 e versioni successive?


Questo articolo è relativo a:
  • Browser: Firefox
  • Versioni Java: 6.0, 6u10+

A partire da Firefox 3.6, le applet basate su Java NON funzioneranno a meno che non venga utilizzato Java 6 Aggiornamento 10 o versioni successive.

Se non sapete qual è la versione di Java in esecuzione sul vostro computer, verificatela. Se state utilizzando una versione di Java precedente a Java 6 Aggiornamento 10, per eseguire le applicazioni Java in Firefox avete due possibilità:

  • Aggiornare Java prima di effettuare l'aggiornamento a Firefox 3.6 e versioni successive. Aggiornando Java alla versione più recente abiliterete inoltre il supporto per il nuovo plug-in Java. Questo plug-in non solo permette di eseguire le applicazioni Java più rapidamente nel browser Web, ma aggiunge inoltre alcune utilissime nuove funzioni, come la possibilità di fare clic e trascinare alcune applicazioni Java dalla finestra del browser Web al desktop.



ULTERIORI INFORMAZIONI TECNICHE

A partire da Firefox 3.6, Mozilla Foundation interromperà il supporto per OJI (Open Java Virtual Machine Integration) e supporterà solo le interfacce standard NPAPI e NPRuntime. Il plug-in Java disponibile in Java 6 Aggiornamento 10 e versioni successive supporta le interfacce NPAPI e NPRuntime. Per questo motivo, a partire da Firefox 3.6, gli applet basati su Java NON funzioneranno a meno che non venga utilizzato Java 6 Aggiornamento 10 o versioni successive.


Pensiamo che potrebbe interessarvi anche:

Scegli una lingua | Informazioni su Java | Supporto | Sviluppatori
Privacy | Termini e condizioni per l'utilizzo | Marchi | Disclaimer

Oracle