Java.com

下載 說明

可列印版本

當不受信任的 Applet 或應用程式在我的 Web 瀏覽器中執行時,我該如何控制它?


本文適用於:
  • Java 版本: 7.0, 8.0

Java 7u10 引進了新的管理功能,無論不受信任的 Java 應用程式 (亦即,經不明發行者數位簽署的應用程式,或未經可信賴的憑證授權單位 (CA) 發行的憑證) 執行的時間及方式為何,只要它們包含在網頁中,便會執行這個管理功能。在「Java 控制面板」內設定安全層次可決定
  1. 您是否會在執行不受信任的 Java 應用程式 (中或高) 之前收到提示,或者
  2. 不受信任的 Java 應用程式會被封鎖而無法執行 (非常高)。

從 Java 7 Update 51 開始,不符合最新安全做法的 Applet 仍可授權執行,方法是將裝載這些 Applet 的網站加入例外網站清單中。

Java 8 Update 20 開始,「中」安全層次已從「Java 控制面板」移除。只有「非常高」和「高」層次可供選擇。

例外網站清單會提供相關選項讓使用者可以根據各個網站來一一允許過去選取選項所允許的 Applet,因此能夠將使用較寬鬆設定會有的風險降到最低。


尋找 Java 控制面板

» Windows
» Mac OS X

從「Java 控制面板」設定安全層次

  1. 在「Java 控制面板」中,按一下安全性標籤。
  2. 選取所需的安全層次。
  3. 按一下套用
  4. 按一下確定即可儲存對「Java 控制面板」進行的變更。
Java 控制面板 - Java 8u20 及更新版本
Java 8u20 控制面板「安全」標籤

Java 控制面板 - Java 7
Java 7 控制面板「安全」標籤


「Java 控制面板」中的安全層次

非常高
這是最高限制安全層次設定。允許以有效憑證簽署的所有應用程式及主要 JAR 檔案的資訊清單中包含「權限」屬性的所有應用程式在顯示安全提示之後執行。封鎖所有其他的應用程式。

這是建議的最低安全性 (也是預設值) 的安全層次設定。允許以有效或過期憑證簽署的應用程式及主要 JAR 檔案的資訊清單中包含「權限」屬性的應用程式在顯示安全提示之後執行。當無法檢查憑證的撤銷狀態時,則在顯示安全提示之後,也允許執行應用程式。封鎖所有其他的應用程式。

中 (已從 Java 8 Update 20 和更新版本中移除)
只會封鎖要求所有權限的未簽署應用程式。允許所有其他的應用程式在顯示安全提示之後執行。不建議選取「中」安全層次,因為這樣做會讓您的電腦在執行惡意應用程式時更容易受到攻擊。


您可能也會對下列項目感興趣::




選擇語言 | 關於 Java | 支援 | 開發人員
隱私權  | 使用條款 | 註冊商標 | 免責聲明

Oracle