|
IKernel.exe - 應用程式錯誤:無法讀取記憶體。
本文適用於:
- 平台:
Windows 2000, Windows XP, Windows 98, Windows ME, Windows 2003
- Java 版本:
1.4.2_xx
症狀
嘗試安裝 Java 2 Runtime Environment, Standard Edition (JRE) 時,出現包含以下錯誤的訊息方塊:
IKernel.exe - 應用程式錯誤
位於 0x771c741a 的指令參考了位於 「0x0...」(任何數字) 的記憶體。
無法讀取記憶體。
按一下 [確定] 以終止程式
錯誤如以下影像所示:
原因
IKernel.exe 應用程式錯誤可能是由於以下原因之一引起的:
- InstallShield 引擎 (iKernel.exe) 或其位於 \Program Files\Common Files\InstallShield\Engine 資料夾中的元件檔案之一可能損壞、毀壞或是為唯讀。
- InstallShield 引擎 (iKernel.exe) 或其位於 \Program Files\Common Files\InstallShield\Engine 資料夾中的元件檔案之一由舊版的 InstallShield 安裝程式留在系統上 (並且該程式與 JRE 安裝程式目前使用的版本不相容)。
- 您正嘗試在已套用 Service Pack 1 和 Windows XP Hotfix Q328310 的 Windows XP 機器上安裝 JRE。
解決方案
以下是針對該錯誤的可能解決方案。請選擇適用於您電腦的方法。
一般解決方案
解決方案 #1:重新命名或移除舊的 InstallShield 引擎資料夾
iKernel.exe 是 InstallShield 程式檔案。
在安裝 JRE 期間,JRE 安裝程式會將 InstallShield 引擎檔案複製到硬碟。這些檔案會複製到資料夾「C:\Program Files\Common Files\InstallShield」中。假設您的系統磁碟機是 C:。
JRE 安裝程式會將此 InstallShield 資料夾作為臨時資料夾使用。安裝程式後,便不再需要或使用該資料夾中的內容。
如果 InstallShield 引擎 (iKernel.exe) 或其位於「\Program Files\Common Files\InstallShield\Engine」資料夾的元件檔案之一損壞、毀壞或為唯讀權限,則可能發生 iKernel.exe 應用程式錯誤。如果 InstallShield 引擎 (iKernel.exe) 或其位於「\Program Files\Common Files\InstallShield\Engine」資料夾的元件檔案之一由舊版的 InstallShield 程式留在系統上,也可能發生該錯誤。該程式與 JRE 安裝程式目前使用的 InstallShield 的版本不相容。
使用者應該重新命名或刪除該資料夾,並重新執行安裝程式。如果在該電腦上找不到正確的引擎檔案,則 InstallShield 安裝程式會更換或安裝正確的引擎檔案。
若要重新命名 InstallShield 引擎資料夾,請執行以下步驟:
- 透過在系統狀態列的 [開始] 功能表上按一下滑鼠右鍵並選取 [檔案總管],來啟動 Windows 檔案總管。您也可以透過同時按下鍵盤上的 Windows 鍵與 E 鍵來啟動 Windows 檔案總管。
- 瀏覽至 C:\Program Files\Common Files\InstallShield\Engine
- 在反白顯示的 [engine] 資料夾上按一下滑鼠右鍵,並選取
[重新命名]。
- 將 [Engine] 資料夾重新命名為 [EngineOld]。
若要刪除 InstallShield 引擎資料夾,請執行以下步驟:
- 透過在系統狀態列的 [開始] 功能表上按一下滑鼠右鍵並選取 [檔案總管],來啟動 Windows 檔案總管。您也可以透過同時按下鍵盤上的 Windows 鍵與 E 鍵來啟動 Windows 檔案總管。
- 瀏覽至 C:\Program Files\Common Files\InstallShield\Engine
- 在反白顯示的 [engine] 資料夾上按一下滑鼠右鍵,並選取
[刪除]。
- 按一下 [確認刪除資料夾] 訊息方塊中的「是」。
刪除或重新命名資料夾「\Program Files\Common Files\InstallShield\Engine」之後,請嘗試重新安裝 JRE。
解決方案 #2:更新 InstallShield 引擎
有時在嘗試修正 iKernel 應用程式錯誤時,您可能必須更新執行 JRE 安裝程式的 InstallShield 引擎。以下說明介紹了如何下載與安裝最新的 iKernel 引擎。
- 透過在系統狀態列的 [開始] 功能表上按一下滑鼠右鍵並選取 [檔案總管],來啟動 Windows 檔案總管。您也可以透過同時按下鍵盤上的 Windows 鍵與 E 鍵來啟動 Windows 檔案總管。
- 瀏覽至 C:\Program Files\Common Files\InstallShield\Engine
- 在反白顯示的 [engine] 資料夾上按一下滑鼠右鍵,並選取
[刪除]。
- 按一下 [確認刪除資料夾] 訊息方塊中的「是」。
- 透過按一下以下連結來下載最新版本的 iKernel 引擎,並將其儲存到您的桌面。
iKernel 更新
- 按兩下下載的 ikernelupdate.exe 檔案以進行安裝。
適用於套用 Service Pack 1 和 Windows XP Hotfix Q328310 的 Windows XP 的解決方案。
解決方案 #3:套用適用於 Windows XP Hotfix Q328310 的修補程式
Window XP Hotfix Q328310 會與 InstallShield 引擎發生衝突,這是因為某個 Win32 API 無法達到預期的執行效果。
現在,可以從「Microsoft 下載中心」下載支援的修正程式。Microsoft 建議您等待下一個包含此修正程式的 Windows XP service pack。
但是,若要解決此問題,請按一下下面的下載連結來下載並安裝修正程式:
http://www.microsoft.com/downloads/
安裝此修補程式應該可以解決此問題。
解決方案 #4:暫時解除安裝 Windows XP Hotfix Q328310
如果解決方案 #3 無法解決您的問題,我們建議您暫時解除安裝 Windows XP Hotfix Q328310。安裝 JRE,然後重新安裝 Windows XP Hotfix Q328310。解除安裝 Windows XP Hotfix Q328310 的說明如下。
備註:並不建議您解除安裝任何 Windows Hotfix,但有可能需要解除安裝,以便在電腦上成功安裝 JRE。成功完成 JRE 的安裝後,請重新安裝 Windows XP Hotfix。
如何解除安裝 Windows Hotfix Q328310
- 透過從系統
[開始] 功能表按一下 [開始]->[設定]->[控制台],開啟 [控制台]。
- 按兩下 [新增或移除程式] 圖示。
- 選取標題為 Windows XP Hotfix (SP2) Q328310 的連結。結果會出現 [新增或移除程式] 螢幕,如下所示。
- 按一下 [移除] 按鈕。將會顯示以下 [Windows XP Q328310 解除安裝精靈] 螢幕。
- 按一下 [下一步] 開始解除安裝 Windows XP Hotfix。
- 如果系統顯示警告訊息,提示您是否要繼續解除安裝,請按一下 [是]。
- 成功移除 Windows XP Hotfix Q328310 之後,系統會顯示下列螢幕。
- 按一下 [完成] 按鈕,完成解除安裝。
- 電腦將自動重新啟動。
- 再次嘗試安裝 JRE。現在,您應該能夠成功地安裝 JRE,並且應該不會再出現錯誤。
必須在成功安裝 JRE 之後重新安裝 Windows XP Hotfix Q328310。以下說明介紹如何重新安裝 Windows XP Hotfix Q328310。
如何安裝 Windows Hotfix Q328310
- 透過從系統
[開始] 功能表按一下 [開始]->[程式集]->[Windows Update] 或 [開始]->[Windows Update] 圖示,移至 Microsoft Windows Update 網站。
您也可以造訪 Microsoft Update 網站。
- 在左側的 Windows Update 瀏覽位址列中,展開「選取要安裝的更新檔」節點。
- 選取 [重大更新和 Service Pack] 連結。
- 找到標題為 328310:安全性更新檔的項目。
- 確定這個項目已經選取了。在此項目的底部,您將看到訊息 - [已選取這個項目] - 並且已停用 [新增] 按鈕。(如果啟用了 [新增] 按鈕,則按一下 [新增] 按鈕以選取此項目。) 選取 Q328310 修正程式後,將出現如下所示的螢幕。
- 選取 [檢視並安裝更新檔] 連結。選取的修正程式 Q328310 將顯示在如下所示的螢幕中。
- 按一下 [立即安裝] 按鈕。
- 在如下所示的 [Microsoft Windows Update - 網頁對話方塊] 上按一下 [接受] 按鈕,開始安裝。
- 成功安裝後,系統會提示使用者重新啟動電腦。
- 透過按一下
[確定],重新啟動電腦以完成安裝。
更多技術資訊
Sun 提供協力廠商聯絡資訊,以協助您尋找技術支援。這些聯絡資訊如有變更,恕不另行通知。Sun 不保證這些協力廠商聯絡資訊的準確性。
本文中述及的協力廠商產品的製造公司與 Sun 無關。對於這些產品的性能或可靠性,Sun 不做任何暗含或明示性的保證。
|