Java

Java in Action 下载 帮助中心

帮助资源

为何在 Java 崩溃后会在桌面上生成 hs_log_pid 日志文件?


本文适用于:
  • 平台: Windows 7, Vista, Windows XP, Windows 2000, Windows 2003
  • Java 版本: 6.0

问题

如果在浏览器中运行小应用程序或应用程序时出现 Java 崩溃情况,则桌面上会出现一个文本 (.log) 文件。该文本文件名以 hs_err_pid 开头。该文件中会出现下列错误消息。
  • 错误消息:“HotSpot 虚拟机检测到意外错误”


原因

小应用程序崩溃的原因有多种。我们当前正在调查此问题的具体根源。下面列出了一些可能的原因。
  • 您所运行的小应用程序或应用程序包含可导致 Java 崩溃的编程错误或缺陷。
  • 您运行的是旧版本的 Java,其中包含可导致 Java 崩溃的缺陷。

解决方案

此特定问题当前正在调查之中。但是,您可以尝试此处列出的方法来解决您的问题。

:桌面上的日志文件可安全删除。

  • 运行 TestVM 小应用程序,以检查是否已在您的系统中正确安装 Java。如果您能运行此小应用程序,则说明已在您的系统中正确安装和配置 Java。问题可能与该特定 Java applet 程序有关。此情况下,请联系网站管理员或软件供应商,告知这一问题。
  • 下载和安装最新的 Java。最新版本可能包含对您的问题的更新或修复。

选择语言 | 关于 Java | 支持选项
隐私政策 | 使用条款 | 注册商标 | 免责声明

Sun Microsystems