Java.com

下载 帮助

可打印版本

有关在 Mac OS X 上安装和使用 Oracle Java 的信息和系统要求


本文适用于:
  • 平台: Macintosh OS X
  • Java 版本: 7.0, 8.0

Oracle Java 版本 7u25 及更低版本已在 OS X 上被 Apple 禁用。更新到最新发行版使得 Java 可以在 Mac OS X 上运行。
» 下载最新版本的 Java

» 是否可以在卸载 Oracle Java 后还原 Apple Java 6?
» 在 Mac 上使用 Java 有哪些系统要求?
» 为什么在 java.com 上找不到适用于 Mac OS X 的 Java 6?
» 能否在 Mac 上将 Chrome 与 Oracle Java 一起使用?
» 如何获取适用于我的 Mac 的 Java ?
» 如何确定 Mac 上是否安装了 Java?
» 如何为 Mac 安装 Java ?
» 如何查看 Mac 上的 Java 版本?
» 如何在 Mac 上启用 Java?
» 如何在 Mac 上清除 Java 高速缓存?
» 如何更新 Mac 上的 Java?
» 如何从 Mac 中卸载 Java?
» 我没有 Mac 版本 10.7.3 (Lion) 或更高版本。如何获取适用于其他 Mac 版本的 Java?
» 是否可以安全地安装 Java 的早期版本或旧版本?
» 通过 Apple 软件更新获取 Java 后为什么小应用程序不运行?
» 为什么 Oracle Java 仅适用于 Mac OS X 10.7.3 及更高版本?
» 自动更新期间安装挂起,我要做什么来获取最新的 Java?
» 为什么无法在 Mac 10.10 (Yosemite) 上安装 Java?
» 尝试通过命令行使用 Java 时,为什么不起作用?
» 如何获取有关 Java 的支持或者提供反馈?


是否可以在卸载 Oracle Java 7 后还原 Apple Java 6?

是,请参阅 Apple 网站上还原 Apple Java 6 的说明。 如果您已经在系统上安装了 JDK 7 或更高版本,但是希望还原 Apple Java 6,则首先需要卸载这些 JDK 版本。请参阅相关说明以卸载 JDK

在 Mac 上使用 Java 有哪些系统要求?
操作系统要求:对于 Java 7 和更高版本,您需要基于 Intel 的 Mac 并且该操作系统运行的是 Mac OS X 版本 10.7.3 (Lion) 及更高版本。在 Mac 上安装 Java 是在系统范围级别进行的,适用于所有用户,并且需要管理员权限。Java 不能针对单个用户进行安装。
浏览器要求:
要在 Mac OS X 上运行 Oracle Java,需要 64 位浏览器(例如 Safari 或 Firefox)。64 位 Chrome 为 beta 版。

为什么在 java.com 上找不到适用于 Mac OS X 的 Java 6?

对于 Java 版本 6 和更低版本,Apple 提供了自己的 Java 版本。对于 Mac OS X 10.6 及以下版本的系统,使用 Apple 菜单上的软件更新功能查看是否有适用于 Mac 的最新 Java 6 版本。有关与 Mac 上的 Apple Java 6 相关的问题,请与 Apple 技术支持联系。Oracle 和 Java.com 仅支持 64 位系统上的 Java 7 和更高版本。

能否在 Mac 上将 Chrome 与 Oracle Java 一起使用?
要在 Mac OS X 上运行 Oracle Java,需要 64 位浏览器(例如 Safari 或 Firefox)。64 位 Chrome 为 beta 版。

如何获取适用于我的 Mac 的 Java?

您可以从 java.com 下载 Java。

如何确定 Mac 上是否安装了 Java?

Mac OS X 10.6 和更低版本:随 Mac OS 预安装了适用于 Apple 的 Java。
Mac OS X 10.7 (Lion) 和更高版本: Mac OS X 版本 10.7 和更高版本中没有预安装 Java。要从 Oracle 获取最新的 Java,您需要 Mac OS X 10.7.3 和更高版本。
如果您已有 Java 7 或更高版本,则在系统首选项下将看到 Java 图标。
Java 版本 6 和更低版本将在 Java Preferences.app 中列出,位于 Mac 的“应用程序”>“实用工具”文件夹下。

如何为 Mac 安装 Java?

请参阅 Mac Java 安装说明

如何查看 Mac 上的 Java 版本?

Mac OS X 10.7.3 和更高版本:在系统首选项下,单击 Java 图标以访问 Java 控制面板,其中列出了您的 Java 版本。
如果在“系统首选项”下未显示 Java 图标,则未安装 Java 7 或更高版本。

如何在 Mac 上启用 Java?

在 Mac 上(Lion 和更高版本)安装 Oracle Java 时,默认情况下将启用 Java。
如果在浏览器中运行 Java 应用程序,则还需要确保在浏览器中启用了 Java
对于 Java 的早期版本,请查看 Apple 支持网站。

如何在 Mac 上清除 Java 高速缓存?

请参阅如何在 Mac 上清除 Java 高速缓存

如何更新 Mac 上的 Java?

请参阅如何在 Mac 上更新 Java

如何从 Mac 中卸载 Java?

请参阅 Mac Java 卸载说明

我没有 Mac 版本 10.7.3 (Lion) 或更高版本。如何获取适用于其他 Mac 版本的 Java?

对于 Java 版本 6 和更低版本,Apple 提供了自己的 Java 版本。使用 Apple 菜单上的软件更新功能查看是否有适用于 Mac 的最新 Apple Java 版本。
使用 Lion Mac OS X 10.7.1 和 10.7.2 的用户应升级到 10.7.3 或更高版本,以便从 Oracle 获取最新的 Java 版本。

是否可以安全地安装 Java 的早期版本或旧版本?

Oracle 强烈建议用户不要使用旧版本的 Java。在系统上安装支持的旧 Java 版本存在严重的安全风险。升级到最新版本的 Java,可确保在运行 Java 应用程序时实现系统的最新安全和性能提升。您可在验证页上确认您的版本是否最新。如果绝对需要安装旧版本的 Java,则必须先卸载当前版本。请参阅 Mac 卸载 Java 常见问题解答上的说明。

通过 Apple 软件更新获取 Java 后为什么小应用程序不运行?

当使用“软件更新”完成 Java 更新时,Apple 将禁用 Java 插件和 Webstart 应用程序。另外,如果 Java 插件检测到小应用程序长时间没有运行,它会再次禁用 Java 插件。

为什么 Oracle Java 仅适用于 Mac OS X 10.7.3 和更高版本?

Java 运行时依赖于所提供的应用程序编程接口 (API)。部分 API 已添加到 Mac OS X 10.7.3 中。Apple 不计划在旧版 Mac OS 上提供这些 API。

自动更新期间安装挂起,我需要做什么才能获取最新的 Java?

自动更新期间,Mac OS X 10.9 (Mavericks) 用户可能会看到安装停止。从 java.com Web 站点下载最新的 Java。

为什么无法在 Mac OS X 10.10 (Yosemite) 上安装 Java?

请参阅 Mac OS X 10.10 常见问题解答

尝试通过命令行使用 java 时,为什么不起作用?我已安装了 Oracle 的 JRE 版本。

安装 Oracle 的 JRE 不会更新 java -version 符号链接或者将 java 添加到您的路径中。如需此功能,您必须安装完整的 JDK。请参阅 Mac 命令行信息

如何获取有关 Java 的支持或者提供反馈?

要报告有关 Java 的问题或者提供反馈,请使用反馈表单提供详细信息。


您可能还有兴趣关注:



选择语言 | 关于 Java | 支持 | 开发人员
隐私政策 | 使用条款 | 商标 | 免责声明

Oracle