Java.com

Ladda ned Hjälp

Utskrivbar version

Information och systemkrav för installation och användning av Oracle Java i Mac OS X


Denna artikel gäller för:
  • Plattformar: Macintosh OS X
  • Java-versioner: 7.0, 8.0

Oracles Java-version 7u25 och tidigare har avaktiverats av Apple på OS X. Genom att uppdatera till den senaste utgåvan kan Java köras på Mac OS X.
» Ladda ned den senaste versionen av Java

» Kan jag återställa Apple Java 6 efter att ha avinstallerat Oracle Java?
» Vilka är systemkraven för Java på min Mac?
» Varför kan jag inte hitta Java 6 för Mac OS X på java.com?
» Kan jag använda Chrome med Oracle Java på min Mac?
» Hur får jag tag på Java för min Mac?
» Hur vet jag att jag har Java installerat på min Mac?
» Hur installerar jag Java för min Mac?
» Hur tar jag reda på vilken version av Java jag har på min Mac?
» Hur aktiverar jag Java på min Mac?
» Hur rensar jag Java-cacheminnet på min Mac?
» Hur uppdaterar jag Java på min Mac?
» Hur avinstallerar jag Java från min Mac?
» Jag har inte Mac version 10.7.3 (Lion) eller senare. Hur får jag tag på Java för andra Mac-versioner?
» Är det säkert att installera tidigare eller äldre versioner av Java?
» Varför körs inte appletar sedan jag hämtat Java via Apple Software Update?
» Varför är Oracle Java endast tillgängligt för Mac OS X 10.7.3 och senare?
» Installationen slutar svara under en automatisk uppdatering, var kan jag hämta den senaste versionen av Java?
» Varför kan jag inte installera Java i Mac OS X 10.10 (Yosemite)?
» Varför fungerar det inte när jag försöker använda Java från kommandoraden?
» Hur får jag support för eller ger återkoppling om Java?


Kan jag återställa Apple Java 6 när jag har avinstallerat Oracle Java 7?

Ja, instruktioner finns på Apples webbsida Återställ Apple Java 6. Om du har installerat JDK 7 eller en senare version på datorn och du vill återställa Apple Java 6 måste du avinstallera de JDK-versionerna först. Se instruktionerna för hur du avinstallerar i Avinstallera JDK.

Vilka är systemkraven för Java på min Mac?
Operativsystemkrav:   För Java 7 och senare versioner behöver du en Intel-baserad Mac som körs med Mac OS X version 10.7.3 (Lion) eller senare. Installationen av Java på en Mac utförs systemövergripande för alla användare, och du behöver administratörsbehörighet. Java kan inte installeras separat för varje användare.
Webbläsarkrav:
En 64-bitars webbläsare (t.ex. Safari eller Firefox) krävs för att köra Oracle Java i Mac OS X. 64-bitars Chrome är i betastadiet.

Varför kan jag inte hitta Java 6 för Mac OS X på java.com?

För Java-versioner 6 eller senare har Apple en egen version av Java. Har du Mac OS 10.6 eller tidigare använder du funktionen för programvaruuppdatering (på Apple-menyn) och kontrollerar att du har den senaste versionen av Java 6 till din Mac. Om du har problem med Apple Java 6 till Mac kan du kontakta Apples support. Endast Oracle och Java.com har stöd för Java 7 och senare och bara på 64-bitarssystem.

Kan jag använda Chrome med Oracle Java på min Mac?
En 64-bitars webbläsare (t.ex. Safari eller Firefox) krävs för att köra Oracle Java i Mac OS X. 64-bitars Chrome är i betastadiet.

Hur får jag tag på Java för min Mac?

Du kan ladda ned Java från java.com.

Hur kontrollerar jag att Java är installerat i Mac?

Mac OS X 10.6 eller senare: Java för Apple är förinstallerat i Mac OS.
Mac OS X 10.7 (Lion) eller senare: Java förinstalleras inte med Mac OS X versionerna 10.7 eller senare. Om du vill använda den senaste Java-versionen från Oracle måste du ha Mac OS X 10.7.3 eller senare.
Om du har Java 7 eller en senare version visas en Java-ikon under Systeminställningar.
Java-versionen 6 och tidigare finns i Java Preferences.app som du hittar i mappen Program > Verktygsprogram i Mac:en.

Hur installerar jag Java för min Mac?

Se installationsinstruktionerna för Java för Mac.

Hur hittar jag vilken version av Java jag har i Mac:en?

Mac OS X 10.7.3 eller senare: Under Systeminställningar klickar du på Java-ikonen för att få åtkomst till Java-kontrollpanelen där Java-versionen visas.
Om ingen Java-ikon visas under Systeminställningar är Java 7 eller senare inte installerat.

Hur aktiverar jag Java i Mac:en?

När du installerar Java på en Mac (Lion eller senare) aktiveras Java som standard.
Om du kör ett Java-program i webbläsaren kontrollerar du också att Java är aktiverat för webbläsaren.
Om du har tidigare versioner av Java besöker du webbplatsen Apple Support.

Hur rensar jag Java-cachen i Mac:en?

Se Så här rensar du Java-cachen i en Mac.

Hur uppdaterar jag Java i Mac:en?

Se Så här uppdaterar du Java-cachen i en Mac.

Hur avinstallerar jag Java i Mac:en?

Se Avinstallationsanvisningar för Mac Java.

Jag har inte Mac version 10.7.3 (Lion) eller senare. Hur får jag tag på Java för andra Mac-versioner?

För Java-versioner 6 eller senare har Apple en egen version av Java. Använd funktionen för programvaruuppdatering (på Apple-menyn) och kontrollera att du har den senaste Java-versionen från Apple till din Mac.
Användare med Lion Mac OS X 10.7.1 och 10.7.2 ska uppgradera till 10.7.3 eller senare versioner så att de kan hämta den senaste Java-versionen från Oracle.

Är det säkert att installera tidigare eller äldre versioner av Java?

Oracle rekommenderar användare att inte använda äldre versioner av Java. Om du installerar gamla versioner av Java som stöds innebär det en allvarlig säkerhetsrisk. Om du uppgraderar till den senaste versionen av Java kan du vara säker på att Java-applikationer kan köras med högsta säkerhets- och prestandaförbättringar på systemet. Du kan kontrollera att du har den senaste versionen på verifieringssidan. Om du måste installera en äldre version av Java måste du först avinstallera aktuell version. Se instruktionerna i frågorna och svaren om avinstallation av Java på en Mac.

Varför körs inte appletar sedan jag hämtat Java via Apple Software Update?

Apple avaktiverar Java plug-in- och Webstart-program när Java-uppdateringen görs med Software Update. Om dessutom Java plug-in upptäcker att inga appletar har körts under en längre tid kommer Java plug-in att avaktiveras.

Varför är Oracle Java endast tillgängligt för Mac OS X 10.7.3 och senare?

Java Runtime är beroende av att ett API-gränssnitt (Application Programming Interface) är tillgängligt. Vissa av API:erna lades till i Mac OS X 10.7.3. Apple har inga planer på att göra dessa API:er tillgängliga för äldre versioner av Mac OS.

Installationen slutar svara under en automatisk uppdatering, var kan jag hämta den senaste versionen av Java?

Installationen kan sluta svara för Mac OS X 10.9-användare (Mavericks) under en automatisk uppdatering. Ladda ned den senaste Java-utgåvan från webbplatsen java.com.

Varför kan jag inte installera Java i Mac OS X 10.10 (Yosemite)?

Se Vanliga frågor och svar för Mac OS X 10.10.

Varför fungerar det inte när jag försöker använda java från kommandoraden? Jag har installerat Oracles version av JRE:n.

När du installerar en JRE från Oracle uppdaterar det inte symboliska länkar för java -version eller lägger till java på din sökväg. För de funktionerna måste du installera det fullständiga JDK:t. Se kommandoradsinformationen för Mac.

Hur får jag support för eller ger återkoppling om Java?

Du kan använda återkopplingsformuläret för att rapportera problem eller ge återkoppling om Java.


Du kanske även är intresserad av:



Välj språk | Om Java | Supportalternativ | Utvecklare
Sekretess | Användningsvillkor | Varumärken | Friskrivning

Oracle