Java.com

Ladda ned Hjälp

Hjälpresurser

Varför behöver jag Java 6 Update 10 eller högre för Firefox 3.6 och senare versioner?


Denna artikel gäller för:
  • Webbläsare: Firefox
  • Java-versioner: 6.0, 6u10+

Från och med Firefox 3.6 kommer Java-baserade program INTE att fungera om du inte kör Java-version 6 Update 10 eller nyare.

Om du är osäker på vilken Java-version du kör bör du kontrollera din version. Om du upptäcker att du kör en äldre Java-version än version 6 Update 10 måste du uppdatera till den senaste Java-versionen för att du även fortsättningsvis ska kunna köra Java-program i Firefox:

  • Uppdatera din Java-version innan du uppdaterar till Firefox 3.6 eller senare versioner. Genom att uppdatera din Java-version till den senaste versionen får du också stöd för det nya Java-insticksprogrammet. Det här insticksprogrammet kör inte bara Java-program snabbare i webbläsaren utan det lägger dessutom till några nya, coola funktioner, som möjligheten att klicka på och dra vissa Java-program från webbläsaren till skrivbordet.



MER TEKNISK INFORMATION

Från och med Firefox 3.6 kommer Mozilla Foundation inte längre att ha stöd för OJI (Open Java Virtual Machine Integration) utan endast ha stöd för standardgränssnitten NPAPI och NPRuntime. Java-insticksprogrammet som finns i Java version 6 Update 10 eller senare versioner har stöd för gränssnitten NPAPI och NPRuntime. Därför kommer, från och med Firefox 3.6, Java-baserade appletprogram INTE att fungera om du inte kör Java version 6 Update 10 eller senare.


Vi tror att du också kan vara intresserad av:

Välj språk | Om Java | Supportalternativ | Utvecklare
Sekretess | Användningsvillkor | Varumärken | Friskrivning

Oracle