Java.com

Fazer Download Ajuda

Versão para Impressão

Quais são os requisitos do sistema Java?


Este artigo aplica-se a:
  • Java version(s): 7.0, 8.0

As informações de requisitos do sistema nesta página representam um subconjunto para fornecer uma visão geral dos browsers e sistemas operacionais suportados.

Requisitos do Sistema Java 8

Informações detalhadas sobre os requisitos do sistema Java 8 estão disponíveis em Configurações Suportadas do Sistema Java 8.

Windows

  • Windows 8 (Desktop)
  • Windows 7
  • Windows Vista SP2
  • Windows Server 2008 R2 SP1 (64 bits)
  • Windows Server 2012 (64 bits)
  • RAM: 128 MB
  • Espaço em disco: 124 MB para JRE; 2 MB para Java Update
  • Processador: no mínimo, um processador Pentium 2 de 266 MHz
  • Browsers: Internet Explorer 9 e versão mais recente, Firefox, Chrome

Mac OS X

  • Mac baseado em Intel executando o Mac OS X 10.8.3+, 10.9+
  • Privilégios de administrador para instalação
  • Browser de 64 bits
Um browser de 64 bits (Safari ou Firefox, por exemplo) é necessário para executar o Java no Mac OS X. O Chrome de 64 bits está em versão beta.

Linux

  • Oracle Linux 5.5+1
  • Oracle Linux 6.x (32 bits), 6.x (64 bits)2
  • Oracle Linux 7.x (64 bits)2
  • Red Hat Enterprise Linux 5.5+1, 6.x (32 bits), 6.x (64 bits)2
  • Ubuntu Linux 12.04 LTS, 13.x
  • Suse Linux Enterprise Server 10 SP2+, 11.x
  • Browsers: Firefox
Requisitos do Sistema Solaris

Consulte as Configurações do Sistema Java 8 suportadas para obter informações sobre plataformas, sistemas operacionais, gerenciadores de desktop e browsers suportados.



Requisitos do Sistema Java 7

Informações detalhadas sobre os requisitos do sistema Java 7 estão disponíveis em Configurações Suportadas do Sistema Java 7.

Windows

  • Windows 8 (Desktop)
  • Windows 7
  • Windows Vista SP2
  • Windows Server 2008
  • Windows Server 2012 (64 bits)
  • RAM: 128 MB
  • Espaço em disco: 124 MB para JRE; 2 MB para Java Update
  • Processador: no mínimo, um processador Pentium 2 de 266 MHz
  • Browsers: Internet Explorer 7.0 e versão mais recente, Firefox 3.6 e versão mais recente, Chrome

Observação: desde 8 de abril de 2014, a Microsoft interrompeu o suporte ao Windows XP e, portanto, ele não é mais oficialmente uma plataforma suportada. Os usuários ainda podem continuar usando as atualizações do Java 7 no Windows XP a seu critério, mas o suporte só será fornecido com as versões do Windows Vista ou posterior da Microsoft Windows. Consulte os Termos de Suporte Específicos para Terceiros nas Políticas de Suporte Técnico do Software Oracle (pdf) para obter detalhes.

Mac OS X

  • Mac baseado em Intel executando o Mac OS X 10.7.3+, 10.8.3+, 10.9+
  • Privilégios de administrador para instalação
  • Browser de 64 bits
Um browser de 64 bits (Safari ou Firefox, por exemplo) é necessário para executar o Java no Mac OS X. O Chrome de 64 bits está em versão beta.

Linux

  • Oracle Linux 5.5+
  • Oracle Linux 6.x (32 bits), 6.x (64 bits)3
  • Oracle Linux 7.x (64 bits)3
  • Red Hat Enterprise Linux 5.5+, 6.x (32 bits), 6.x (64 bits)3
  • Ubuntu Linux* 10.04 e versões posteriores
  • Suse Linux Enterprise Server* 10 SP2, 11.x
  • Browsers: Firefox 3.6 e versões posteriores
Requisitos do Sistema Solaris

Consulte as Configurações do Sistema Java 7 suportadas para obter informações sobre plataformas, sistemas operacionais, gerenciadores de desktop e browsers suportados.


Observações

1 Nenhum suporte a JavaFX
2Somente JRE de 64 bits é suportado
3 Somente JVM de 64 bits é certificado.


Selecionar Idioma | Sobre o Java | Suporte | Desenvolvedores
Privacidade | Termos de Uso | Marcas Comerciais | Isenção de Responsabilidade

Oracle