Java.com

Fazer Download Ajuda

Versão para Impressão

Por que os arquivos de log hs_log_pid foram colocados na área de trabalho após um travamento de Java?


Este artigo aplica-se a:
  • Plataforma(s): Windows 7, Vista, Windows XP, Windows 2000, Windows 2003
  • Java version(s): 6.0, 7.0, 8.0

SINTOMAS

Um travamento de Java ocorre enquanto se executa um applet ou aplicativo em um navegador, e um arquivo de texto (.log) aparece na área de trabalho. O nome do arquivo de texto começa com hs_err_pid . A seguinte mensagem de erro aparece no arquivo.
Mensagem de erro: 'An unexpected error has been detected by HotSpot Virtual Machine' (Foi detectado um erro inesperado pelo HotSpot Virtual Machine)


MOTIVO

Há vários motivos possíveis para o travamento do applet. No momento estamos investigando o que exatamente provoca este problema. Esta é uma lista de alguns motivos possíveis:
  • O applet ou o aplicativo que estava em execução pode conter erros de programação ou bugs que provocaram o travamento do Java.
  • Talvez você esteja executando uma versão anterior do Java, que pode conter bugs que podem fazer o Java travar.

SOLUÇÃO

Este problema específico está sendo investigado. Entretanto, é possível tentar as coisas listadas aqui para resolver o problema.

Nota: os arquivos de log na área de trabalho podem ser excluídos com segurança.

  • Execute o applet TestVM para verificar se o Java está instalado corretamente no sistema. Se você conseguir executar esse applet, isso significa que o Java está instalado e configurado corretamente no sistema. O problema pode ser específico desse applet. Nesse caso, entre em contato com os administradores do site ou com o fornecedor do software para notificá-los do problema.
  • Baixe e instale o Java mais recente. A versão mais recente pode conter atualizações ou correções para o problema.

Selecionar Idioma | Sobre o Java | Suporte | Desenvolvedores
Privacidade | Termos de Uso | Marcas Comerciais | Isenção de Responsabilidade

Oracle