Java.com

Fazer Download Ajuda

Versão para Impressão

Como executo ou ativo o Java no browser?


Este artigo aplica-se a:
  • Plataforma(s): Macintosh OS X, Windows 2000, Windows 7, Windows 8, Windows XP
  • Versão(ões) do Java: Chrome, Firefox
  • Java version(s): 7.0

Internet Explorer - Bloqueio do Controle ActiveX desatualizado

O Internet Explorer (IE) tem uma nova funcionalidade de segurança, denominada bloqueio do controle ActiveX, para manter atualizados os controles do ActiveX, como o Java. Esta funcionalidade impedirá que a aplicação ou a página Web seja carregada se considerar que o Java está desatualizado. Neste caso, fornecerá a opção para atualizar o Java.

O Java(TM) foi bloqueado porque está desatualizado
Quando o controle ActiveX bloquear uma versão anterior do Java, você verá o seguinte:
  • No Internet Explorer: uma barra de notificação, semelhante a uma mensagem informando que o Java(TM) foi bloqueado porque está desatualizado e precisa ser atualizado, bem como opções para Atualizar ou Executar desta vez
  • Fora do IE: uma caixa de diálogo de Segurança do Internet Explorer e uma mensagem Um site deseja abrir o conteúdo web usando um programa desatualizado no computador, bem como opções para Permitir ou Não Permitir a execução da aplicação e a opção para Atualizar a versão antiga.
Atualizar o Java

É recomendável atualizar o Java antes de permitir que a aplicação seja executada. Clique em Atualizar e faça download da versão mais recente do Java. Se você não confiar no site ou no prompt, poderá acessar o site java.com para obter a versão mais atual.

O bloqueio do controle ActiveX desatualizado aplica-se ao seguinte:
  • Windows 7 SP1 - Internet Explorer 8 até Internet Explorer 11
  • Windows 8 Internet Explorer para desktop
» Bloqueio do controle ActiveX (blog da Microsoft)


Firefox - Ativar plug-in Java

O Firefox implementou uma nova funcionalidade de segurança Clique-para-Tocar que protege contra ataques, direcionado a plug-ins que são conhecidos por serem vulneráveis. Essa funcionalidade impede que os applets sejam carregados automaticamente e permite aos usuários controlar o conteúdo que desejam executar ou evitar.

  • Se você tentar executar um applet Java utilizando uma versão do plug-in Java que é identificada como vulnerável, o Firefox impedirá que o applet seja carregado automaticamente e o alertará de que o plug-in é vulnerável.
  • Se uma atualização estiver disponível, o Firefox oferecerá a opção de atualizar ou ativar o plug-in. Recomendamos procurar atualizações, antes de ativar o plug-in.
  • Além disso, o Firefox oferece uma opção de bloquear ou ativar automaticamente o plug-in por site.

» Clique para Tocar no Firefox (mozilla.org)


Chrome - Executar plug-in Java

O browser Chrome bloqueia versões do plug-in Java que estão desatualizadas ou que foram identificadas com riscos de segurança. Uma mensagem o notifica de que o plug-in está bloqueado.

Plug-in desatualizado

Recomendamos atualizar o plug-in antes de permitir que ele seja executado.

O Java(TM) precisa de sua permissão para ser executado
  • Se você escolher Executar desta vez, o plug-in será executado, mas você será solicitado por permissão da próxima vez que visitar o site
  • Se você escolher Sempre executar neste site, o plug-in será executado e não solicitará permissão quando você visitar o site novamente.

Além disso, você pode personalizar o modo como o Chrome trata os plug-ins (Clique para Tocar ou Bloquear Todos) nas Definições de Conteúdo do Chrome.
» Chrome plug-in (support.google.com)
» Chrome out of date plug-in (support.google.com)
» Chrome blocked plug-in (support.google.com)

Selecionar Idioma | Sobre o Java | Suporte | Desenvolvedores
Privacidade | Termos de Uso | Marcas Comerciais | Isenção de Responsabilidade

Oracle