Java.com

Downloaden Help

Afdrukbare versie

Hoe kan ik Java in de browser uitvoeren of activeren?


Dit artikel is van toepassing op:
  • Platform(s): Macintosh OS X, Windows 2000, Windows 7, Windows 8, Windows XP
  • Browser(s) Chrome, Firefox
  • Java-versie(s): 7.0

Internet Explorer: verouderd ActiveX-besturingselement blokkeren

Internet Explorer (IE) heeft een nieuwe beveiligingsfunctie, ActiveX-besturingselement blokkeren, die zorgt dat ActiveX-besturingselementen, zoals Java, steeds worden bijgewerkt. Deze functie voorkomt dat een applicatie of webpagina wordt geladen als blijkt dat Java is verouderd en biedt de optie Java bij te werken.

Java(TM) is geblokkeerd, omdat deze verouderd is.
Als het ActiveX-besturingselement een oudere versie van Java blokkeert, ziet u:
  • In Internet Explorer: een meldingsbalk in de trant van Java(TM) is geblokkeerd, omdat deze verouderd is en moet worden bijgewerkt en opties voor Bijwerken of Eenmalig uitvoeren
  • Buiten IE: een beveiligingsvenster van Internet Explorer, Er wordt geprobeerd webinhoud te openen met een verouderd programma op uw computer en opties voor het Toestaan of Niet toestaan van het uitvoeren van de applicatie. Daarnaast krijgt u de optie voor het Bijwerken van de oude versie.
Java bijwerken

Het is aan te raden Java bij te werken voordat u de applicatie laat uitvoeren. Klik op Bijwerken en download de nieuwste Java-versie. Als u de website of prompt niet vertrouwt, kunt u via de website java.com de laatste versie downloaden.

Verouderd ActiveX-besturingselement blokkeren is van toepassing op:
  • Windows 7 SP1 Internet Explorer 8 tot en met Internet Explorer 11
  • Windows 8 Internet Explorer voor desktop
» ActiveX control blocking (Microsoft blog)


Firefox: Java-plug-in activeren

In Firefox is een nieuwe Click to Play-beveiligingsfunctie geïmplementeerd die kwetsbare plug-ins tegen aanvallen beschermt. Met behulp van deze functie wordt voorkomen dat applets automatisch worden geladen, en kunnen gebruikers beheren welke inhoud ze willen uitvoeren of vermijden.

  • Als u een Java-applet wilt uitvoeren met behulp van een Java-plug-in-versie die als kwetsbaar is geïdentificeerd, wordt door Firefox voorkomen dat de applet automatisch wordt geladen. U krijgt een waarschuwing dat de plug-in kwetsbaar is.
  • Als er een update beschikbaar is, wordt in Firefox de optie geboden om de plug-in bij te werken of te activeren. U wordt aangeraden om eerst op updates te controleren voordat u de plug-in activeert.
  • Daarnaast wordt in Firefox de optie geboden om de plug-in per site te blokkeren of automatisch te activeren.

» Click to Play in Firefox (mozilla.org)


Chrome: Java-plug-in uitvoeren

In de Chrome browser worden Java-plug-in-versies geblokkeerd als deze zijn verouderd of beveiligingsrisico's bevatten. Er wordt een bericht weergegeven dat de plug-in is geblokkeerd.

Verouderde plug-in

U wordt aangeraden om de plug-in eerst bij te werken voordat u toestemming geeft om deze uit te voeren.

Voor uitvoering van Java(TM) is uw toestemming nodig.
  • Als u Deze keer uitvoeren selecteert, wordt de plug-in uitgevoerd maar u wordt de eerstvolgende keer dat u de site bezoekt om autorisatie gevraagd.
  • Als u Altijd voor deze site uitvoeren selecteert, wordt de plug-in uitgevoerd en u wordt niet meer om autorisatie gevraagd als u de site opnieuw bezoekt.

Daarnaast kunt u de verwerking van plug-ins in Chrome ('Click to Play' of 'Alles blokkeren') aanpassen onder 'Instellingen voor inhoud' in Chrome.
» Chrome plug-in (support.google.com)
» Verouderde Chrome plug-in (support.google.com)
» Geblokkeerde Chrome plug-in (support.google.com)

Taal kiezen | Info over Java | Ondersteuning | Ontwikkelaars
Privacy | Voorwaarden voor gebruik | Handelsmerken | Afwijzing van aansprakelijkheid

Oracle