Java.com

다운로드 도움말

도움말 리소스

Java 7 Update 10(7u10) 이상을 설치한 후 Firefox에서 Java 플러그인이 작동하지 않음


적용 대상::
  • 브라우저: Firefox
  • Java 버전: 7.0

증상

Java 7u10 이상 설치 완료 시 다음 오류가 나타납니다.
오류: 이 콘텐츠를 표시하려면 플러그인이 필요합니다. 플러그인 설치


원인

Java 버전 7u10 이상과 독립형 JavaFX 설치 사이의 충돌 때문입니다.
예제: Java 7u5와 JavaFX 2.1.1이 설치되었고 Java 7u10으로 업데이트할 경우 Firefox에서 Java 7u10이 설치되었음을 감지할 수 없습니다.


해결책

이 문제를 해결하려면 Java 버전 7u10 이상을 설치하기 전에 모든 Java 및 JavaFX 버전을 제거할 것을 권장합니다.
이 문제를 해결하려면 다음 단계를 수행하십시오.
  1. Windows 제거 제어판을 통해 모든 Java 및 JavaFX 버전을 제거합니다.
    Java 제거에 대한 지침.
  2. Microsoft 제거 유틸리티를 실행하여 손상된 레지스트리 키를 복구합니다. 그렇지 않으면 프로그램이 완전히 제거되지 않거나 새로운 설치 및 업데이트가 차단됩니다.
  3. Windows 오프라인 설치 프로그램 패키지를 다운로드하여 설치합니다.

언어 선택 | Java 정보 | 지원 | 개발자
개인 정보 보호 정책 | 사용 약관 | 등록 상표 | 보증의 부인

Oracle