Java

Java in Azione Download Centro di assistenza

Risorse di assistenza

Perché Microsoft Internet Explorer 9 si blocca quando si apre una pagina Web contenente applet Java?


Questo articolo è relativo a:
  • Piattaforme: Windows 7, Vista, Windows XP, Windows 2000
  • Browser: Internet Explorer
  • Versioni Java: 6.0

SINTOMI

Quando si visita una pagina Web contenente delle applet utilizzando Internet Explorer 9, il browser si blocca.


CAUSA

Questi sono alcuni dei motivi che potrebbero causare il blocco di Internet Explorer 9.

Per eseguire le applet Java in un browser Internet Explorer 9, è necessario che sia installata la versione Java 6u24 o superiore.

  • Non è installata la versione di Java più recente
  • È possibile che sia disattivata l'opzione Impostazioni Visualizzazione Compatibilità in IE 9

SOLUZIONE

Di seguito sono riportate le operazioni consigliate per risolvere questo problema.
  1. Installare la versione più recente di Java:
    • La versione più recente è disponibile qui
      Il problema è stato risolto utilizzando la versione Java6u24 che ha aggirato la funzionalità ActiveX Filtering di IE 9. Pertanto, le applet Java dovrebbero funzionare correttamente con questa versione.
  2. Attivare le Impostazioni Visualizzazione Compatibilità in IE 9
    • Aprire il browser IE 9
    • Fare clic sulla scheda Strumenti
    • Selezionare l'opzione Impostazioni Visualizzazione Compatibilità
    • Fare clic sul pulsante Aggiungi
    • Aggiungere il sito Web

Scegli una lingua | Informazioni su Java | Supporto
Privacy | Condizioni di utilizzo | Marchi | Disclaimer

Sun Microsystems