Java.com

Télécharger Aide

Ressources d'aide

Le plug-in Java ne fonctionne pas dans Firefox après l'installation de Java 7 Update 10 (7u10) et versions supérieures.


Cet article s'applique aux éléments suivants ::
  • Navigateur(s): Firefox
  • Version(s) de Java: 7.0

SYMPTÔMES

A la fin de l'installation de Java 7u10 et versions supérieures, l'erreur suivante apparaît :
Erreur : un plug-in est nécessaire pour afficher ce contenu. Installer le plug-in


CAUSE

Ceci est dû à un conflit entre Java 7u10 (et versions supérieures) et des installations autonomes de JavaFX.
Exemple : si Java 7u5 et JavaFX 2.1.1 sont installés et que Java est mis à jour vers 7u10, Firefox ne peut pas détecter que Java 7u10 est installé.


SOLUTION

Pour résoudre ce problème, il est recommandé de désinstaller toutes les versions de Java et JavaFX avant d'installer Java 7u10 et versions supérieures.
Pour résoudre ce problème, procédez comme suit :
  1. Supprimez toutes les versions de Java et JavaFX via le Panneau de configuration de désinstallation de Windows.
    Instructions de désinstallation de Java.
  2. Exécutez l'utilitaire de désinstallation Microsoft pour réparer les clés de registre endommagées qui empêchent la désinstallation complète des programmes ou qui bloquent les nouvelles installations et les mises à jour.
  3. Téléchargez et installez le package du programme d'installation hors ligne de Windows.

Sélectionner une langue | A propos de Java | Support technique | Développeurs
Politique de confidentialité | Conditions d'utilisation | Marques déposées | Avis d'exclusion de responsabilité

Oracle