Java.com

Télécharger Aide

Exécution ou activation de Java dans le navigateur


Cet article s'applique aux éléments suivants:
  • Plate(s)-forme(s): Macintosh OS X, Windows 2000, Windows 7, Windows 8, Windows XP
  • Navigateur(s): Chrome, Firefox
  • Version(s) de Java: 7.0

Internet Explorer : blocage des contrôles ActiveX obsolètes

Internet Explorer (IE) dispose d'une nouvelle fonctionnalité de sécurité, le blocage des contrôles ActiveX. Celle-ci garantit que les contrôles ActiveX, tels que Java, sont à jour. Elle empêche le chargement d'une application ou d'une page Web si une version obsolète de Java est détectée, et elle propose de mettre à jour Java.

Java(TM) a été bloqué en raison d'une version obsolète.
Lorsque le contrôle ActiveX bloque une ancienne version de Java, vous obtenez le résultat suivant :
  • Dans Internet Explorer : une barre de notification indiquant que Java(TM) a été bloqué en raison d'une version obsolète et doit être mis à jour, ainsi que les options Mettre à jour et Exécuter cette fois.
  • En dehors d'Internet Explorer : une boîte de dialogue de sécurité d'Internet Explorer indiquant qu'un site Web souhaite ouvrir un contenu Web utilisant un programme obsolète sur votre ordinateur, ainsi que les options Autoriser et Ne pas autoriser pour l'exécution de l'application. Vous pouvez également Mettre à jour l'ancienne version.
Mettre à jour Java

Il est recommandé de mettre à jour Java avant d'autoriser l'exécution de l'application. Cliquez sur Mettre à jour et téléchargez la dernière version de Java. Si vous ne faites pas confiance au site ou à l'invite, rendez-vous sur le site java.com pour obtenir la dernière version.

Le blocage des contrôles ActiveX obsolètes s'applique aux programmes suivants :
  • Windows 7 SP1 : Internet Explorer 8 à Internet Explorer 11
  • Windows 8 : Internet Explorer (version de bureau)
» Blocage des contrôles ActiveX (blog Microsoft)


Firefox - Activation du plug-in Java

Firefox implémente une nouvelle fonctionnalité de sécurité Cliquer pour lire pour la protection contre les attaques, qui cible les plug-ins connus pour être vulnérables. Cette fonctionnalité empêche le chargement automatique des applets et permet aux utilisateurs de contrôler le contenu qu'ils veulent exécuter ou éviter.

  • Si vous essayez d'exécuter une applet Java à l'aide d'une version de plug-in Java identifiée comme vulnérable, Firefox empêche le chargement automatique de l'applet et vous signale que le plug-in est vulnérable.
  • Si une mise à jour est disponible, Firefox offre la possibilité de mettre à jour ou d'activer le plug-in. Nous recommandons de rechercher les mises à jour avant d'activer le plug-in.
  • De plus, Firefox fournit une option qui permet de bloquer ou d'activer automatiquement le plug-in site par site.

» Fonction Cliquer pour lire sur Firefox (mozilla.org)


Chrome - Exécution du plug-in Java

Le navigateur Chrome bloque les versions du plug-in Java qui sont obsolètes ou ont été identifiées avec des risques de sécurité. Un message vous avertit que le plug-in est bloqué.

Plug-in obsolète

Nous vous recommandons de mettre à jour le plug-in avant d'autoriser son exécution.

L'exécution de Java(TM) requiert votre autorisation
  • Si vous choisissez de l'exécuter cette fois, le plug-in est exécuté mais votre autorisation sera demandée la prochaine fois que vous consulterez le site.
  • Si vous choisissez de toujours l'exécuter sur ce site, le plug-in est exécuté et votre autorisation ne sera pas demandée au prochain accès au site.

De plus, vous pouvez personnaliser la façon dont Chrome gère les plug-ins (Cliquer pour lire ou Tout bloquer) dans Chrome - Paramètres de contenu.
» Chrome - Plug-ins (support.google.com)
» Chrome - Plug-ins obsolètes (support.google.com)
» Chrome - Plug-ins bloqués (support.google.com)

Sélectionner une langue | A propos de Java | Support technique | Développeurs
Politique de confidentialité | Conditions d'utilisation | Trademarks | Avis de non-responsabilité

Oracle