Error: <\bin\hotspot\jvm.dll> error message during install process
This article applies to:
Platform(s):
Windows 98
,
Windows ME
,
Windows 2000
,
Windows XP
,
Windows 2003
Browser(s):
All Browsers
Java version(s):
1.5.0
SYMPTOMS
During the Java Runtime Environment (JRE) installation process, you get the following message
"Java Runtime Environment cannot be loaded from </bin/hotspot/jvm.dll>"
CAUSE
The problem could be either caused by corrupted registry keys or incomplete installation.
SOLUTION
I. Delete the deployment.properties fileRemove the deployment.properties file and run the installation again. The deployment.properties file is usually located in: “C:\Documents and Settings\<username>\Application Data\Sun\Java\Deployment” (where username is your login name) directory. The installation process will create a new deployment.properties file.
To remove the deployment.properties file, follow these steps:
Click on Start > My Computer
Go to “\Documents and Settings” directory
Go to username sub-directory (username is your computer login name )
Go to Application Data\Sun\Java\Deployment directory
Delete the deployment.properties file
Run the installation process again
If this does not solve your problem, you might need to run the Microsoft Cleanup Utility and try installing again.II. Using Microsoft Windows Installer Cleanup tool:Note: This tool will ensure that all irrelevant Java Runtime Environment Microsoft Installer (msi) registries are removed. Detailed information and download is available at: Description of the Windows Installer CleanUp Utility